วิธีแก้อัพเดท Ubuntu ผ่าน GUI ไม่ได้ (Could not Initialize the package information)

          ก่อนอื่นต้องออกตัวว่า ไม่ได้เชี่ยวชาญกับเจ้า  Ubuntu มากนะ แต่ผมก็ได้ลงเจ้า os ตัวนี้ไว้ในเครื่องด้วย เป็น os ที่ 2 นอกจาก Windows 7 เพื่อศึกษาและลองใช้งานมันดู ซึ่งตอนนี้มันก็มีอัพเดทเป็น version 12 แล้ว ซึ่งการใช้งานโดยปกติทั่วไป ก็ไม่มีปัญหาอะไร บางครั้งผมว่ามันใช้ง่ายกว่า Windows ที่เราใช้ๆกันอยู่ทุกวันนี้


แต่วันนี้หลังจากผมได้ทำการ Update ซึ่งปกติก็จะ Update ผ่าน GUI เพราะมันสะดวกกว่า และอีกอย่างก็คือ ยังไม่ค่อยถนัด command line ของเจ้า Ubuntu ซักเท่าไร แต่มาเจอปัญหาว่า ครั้งนี้มันไม่สามารถ Update ผ่านปกติเหมือนครั้งก่อนๆ คือจะขึ้น error ตามรูปด้านล่าง
Could not Initialize the package information ซึ่งก็ไม่ทราบเหมือนกันว่า มันเกิดจากอะไร






วิธีแก้อัพเดท Ubuntu ผ่าน GUI ไม่ได้ซึ่งหลังจากไปหาข้อมูลใน Internet มาแล้วก็มีหลายวิธีแก้ แต่ผมของลองแบบนี้ก่อนคือเข้าไป update ผ่าน command line

เริ่มด้วยการเปิด Terminal ขึ้นมาก่อน จากนั้นพิมพ์คำว่า
sudo apt-get update   เป็นการ update รายชื่อโปรแกรม version ล่าสุดออกมาก่อน (ใช้ sudo ก่อน เพราะการอัพเดทต้องใช้สิทธิ root )


จากนั้นก็กด enter เพื่อรัน command รอจนมันครบ 100% ทุกตัว เมื่อเสร็จก็ตามด้วย
sudo apt-get upgrade   เป็นการ update โปรแกรมล่าสุดของ Ubantu  รอจนเสร็จ 100% เช่นเดิม


 หากไม่ผิดพลาดอะไรโปรแกรมเรา ก็จะเป็นได้รับการ update ล่าสุดแล้วครับ หลังจากนั้นองไปดู error ที่เกิดขึ้นตอนแรก ก็ไม่มีให้เห็นแล้ว หลังจากนั้นครั้งหลัง ก็เลยลอง update ผ่าน GUI อีกว่าได้ไหม ปรากฏว่าสามารถ update ได้ปกติแล้วครับ 




Advertisement

Advertisement
    Blogger Comment
    Facebook Comment

0 ความคิดเห็น:

แสดงความคิดเห็น